Problem running Shared VMs on Windows 2008 R2 in WMware Workstation 9.0.2

July 28, 2013 – 9:14 am


After I had removed “ localhost” from the Windows hosts file, everything works fine now

I have installed WMware Workstation 9.0.2 on a Windows 2008 R2 Server. Everything works fine, except I cannot enable sharing of VMs in the configuration.

The WMware Workstation server service starts, but dies after a few seconds. I have already searched the usual sources for a solution. ( replacing datasources.xml, re-installing the software after removing all previously installed components and cleaning the registry … ) I also made sure that the HTTPS port is not in use. Nothing helped.

I installed the software on a VM running Windows 2008 R2 and it worked immediately. I replaced the files on the physical machine with the ones from the VM. Same issue …

I really cannot figure out, what is going wrong. From the log I can see, that the service dies, while the software continues logging on the VM with the working setup.


Here is some more information from the log. Perhaps someone can tell, what is going on …

2013-07-28T09:47:02.376+02:00 [02172 info 'Proxysvc'] Proxy config filepath is C:\ProgramData\VMware\hostd\proxy.xml
2013-07-28T09:47:02.376+02:00 [02172 trivia 'TCP'] getaddrinfo((null), 9443, &hints, &result) returns {[::]:9443,}
2013-07-28T09:47:02.376+02:00 [02172 info 'TCP'] WSASocket(23, SOCK_STREAM, 0, NULL, 0, WSA_FLAG_OVERLAPPED)returns 904
2013-07-28T09:47:02.376+02:00 [02172 info 'TCP'] CreateIoCompletionPort(handle=904, _iocp=28, key=1, NULL)
2013-07-28T09:47:02.376+02:00 [03116 info 'Default'] Thread attached
2013-07-28T09:47:02.376+02:00 [03116 info 'ThreadPool'] Thread enlisted
2013-07-28T09:47:02.376+02:00 [02172 trivia 'TCP'] bind(socket=904, addr=[::]:9443, len=28)
2013-07-28T09:47:02.376+02:00 [02172 trivia 'TCP'] listen(904, SOMAXCONN)
2013-07-28T09:47:02.376+02:00 [02172 info 'TCP'] WSASocket(2, SOCK_STREAM, 0, NULL, 0, WSA_FLAG_OVERLAPPED)returns 908
2013-07-28T09:47:02.376+02:00 [02172 info 'TCP'] CreateIoCompletionPort(handle=908, _iocp=28, key=1, NULL)
2013-07-28T09:47:02.376+02:00 [02172 trivia 'TCP'] bind(socket=908, addr=, len=16)
2013-07-28T09:47:02.376+02:00 [02172 trivia 'TCP'] listen(908, SOMAXCONN)
2013-07-28T09:47:02.376+02:00 [02172 info 'Proxysvc'] Plugin initialized
2013-07-28T09:47:02.376+02:00 [02172 info 'Nfc'] Startup breakpoint disabled
2013-07-28T09:47:02.376+02:00 [02172 info 'Nfc'] Mockup false
2013-07-28T09:47:02.376+02:00 [02172 info 'Nfc'] File Services initialized fmgr([class NfcSvc::NfcFileManager:0231E1D8])
2013-07-28T09:47:02.376+02:00 [02172 info 'NfcManager'] [NfcManagerImpl] NfcManagerImpl created
2013-07-28T09:47:02.392+02:00 [02172 info 'Ovfmgrsvc'] Plugin initialized
2013-07-28T09:47:02.392+02:00 [02172 info 'Statssvc'] Initializing statssvc plugin
2013-07-28T09:47:02.392+02:00 [02172 info 'vim.PerformanceManager'] Collection interval is 20 sec
2013-07-28T09:47:02.392+02:00 [02172 error 'vim.PerformanceManager'] Stats Depot has future timestamps. Discarding old statistics information
2013-07-28T09:47:02.392+02:00 [02172 warning 'vim.PerformanceManager'] Reverting to default stats configuration
2013-07-28T09:47:02.439+02:00 [02172 info 'SupportsvcPlugin'] Plugin initialized
2013-07-28T09:47:02.439+02:00 [02172 info 'VcsvcPlugin'] Plugin initialized
2013-07-28T09:47:02.439+02:00 [02172 info 'ha-host'] About:(vim.AboutInfo) {
--> dynamicType = ,
--> name = "VMware Workstation",
--> fullName = "VMware Workstation build-1031769",
--> vendor = "VMware, Inc.",
--> version = "9.0.2",
--> build = "1031769",
--> localeVersion = ,
--> localeBuild = ,
--> osType = "win32-x86",
--> productLineId = "ws",
--> apiType = "HostAgent",
--> apiVersion = "5.1",
--> instanceUuid = ,
--> licenseProductName = "VMware Workstation",
--> licenseProductVersion = "9.0",
--> }
2013-07-28T09:47:02.439+02:00 [02172 info 'ha-host'] Initialized StoragerRM/Vmsvc powering-on interceptor
2013-07-28T09:47:02.470+02:00 [02172 info 'HostsvcPlugin'] Plugin started
2013-07-28T09:47:02.470+02:00 [02172 info 'HttpSvc.HTTPService'] Using default for nonChunkingAgents: 'VMware VI Client|VMware-client|VMware-client/3.*'
2013-07-28T09:47:02.470+02:00 [02172 info 'HttpSvc.HTTPService'] Using default for agentsNeedingContentLength: 'VMware-client'
2013-07-28T09:47:02.470+02:00 [02172 info 'HttpSvc.HTTPService'] Max buffered response size is 104857600 bytes
2013-07-28T09:47:02.470+02:00 [02172 warning 'WelcomePageCustomizer'] Error loading OEM link information. The system cannot find the path specified.
2013-07-28T09:47:02.470+02:00 [02172 verbose 'WelcomePageCustomizer'] Created customizer with oem file '/etc/vmware/oem.xml' and dynDataUrl '/dyndata.js'.
2013-07-28T09:47:02.470+02:00 [02172 info 'HTTP server'] HTTP server created with docroots C:\Program Files (x86)\VMware\VMware Workstation\hostd/extensions/;C:\Program Files (x86)\VMware\VMware Workstation\hostd/vimLocale/;C:\Program Files (x86)\VMware\VMware Workstation\hostd/coreLocale/;C:\Program Files (x86)\VMware\VMware Workstation\hostd/docroot/, chunked responses enabled: true
2013-07-28T09:47:02.470+02:00 [02172 info 'Solo'] soapPort: 8307
2013-07-28T09:47:02.470+02:00 [02172 trivia 'TCP'] getaddrinfo(localhost, 8307, &hints, &result) returns {,}
2013-07-28T09:47:02.470+02:00 [02172 info 'TCP'] WSASocket(2, SOCK_STREAM, 0, NULL, 0, WSA_FLAG_OVERLAPPED)returns 920
2013-07-28T09:47:02.470+02:00 [02172 info 'TCP'] CreateIoCompletionPort(handle=920, _iocp=28, key=1, NULL)
2013-07-28T09:47:02.470+02:00 [02172 trivia 'TCP'] bind(socket=920, addr=, len=16)
2013-07-28T09:47:02.470+02:00 [02172 trivia 'TCP'] listen(920, SOMAXCONN)
2013-07-28T09:47:02.470+02:00 [02172 verbose 'TCP'] closesocket(920)
2013-07-28T09:47:02.470+02:00 [02172 info 'Default'] Win32 service stopped
2013-07-28T09:47:02.470+02:00 [02172 info 'Default'] Thread detached


  1. 3 Responses to “Problem running Shared VMs on Windows 2008 R2 in WMware Workstation 9.0.2”

  2. Have you tried to disable the windows firewall on the failing server?

    By Ralf m Petter on Jul 28, 2013

  3. yes, FW is disabled

    By Ulrich Krause on Jul 28, 2013

  4. SOLVED!! – See update in post

    By Ulrich Krause on Jul 28, 2013

Sorry, comments for this entry are closed at this time.