Archive for the ‘Articles’ Category

Telekom, O-Zwei und ich

Wednesday, December 2nd, 2015

Welchen Kleinkrieg die unterschiedlichen Telefonanbieter in Deutschland untereinander auch immer ausfechten; der Kunde ist der Leidtragende.Am Freitag kam endlich der Telekomiker. Gut 3 Wochen nach Beauftragung eines O2 DSL Anschlusses. Wenn ich gewusst hätte, wie das ended, ich hätte ihm keinen Kaffee angeboten. Nach gut 20 Minuten ist er unverrichteter Dinge wieder ...

[Vaadin] – widgetsets ‘com.vaadin.defaultwidgetset’ does not contain implementation for com.vaadin.addon.charts

Sunday, November 15th, 2015

While working on the IBM Vaadin Challenge, I ran into an issue after adding the charts component to may new project.I implemented the charts components by adding the the following line to my ivy.xml file and recompiled the widgetset.Never the less, the error message appeared. If you ( like me ) ...

Build Windows executables on Linux

Friday, October 23rd, 2015

If you have to build a binary ( .exe, .dll, ... ) from source code for LINUX and WINDOWS, you need at least one build environment for each operating system. In today's world, this is not a big deal, because we can have as many virtual machines as we want thanks ...

[C++] – A plain simple sample to write to and read from shared memory

Tuesday, September 15th, 2015

If you have two programs ( or two threads ) running on the same computer, you might need a mechanism to share information amongst both programs or transfer values from one program to the other.One of the possible solutions is "shared memory". Most of us know shared memory only from ...

[How To] – Create your own IBM Notes Splash Screen

Saturday, September 12th, 2015

Inspired from Thomas Bahn's post, I started to play with the IBM Notes Start Screen.My first "creation" was "YellowVerse 9".This technote describes what you need to replace the original start screen with your own creation.It is important, that you save your image as Windows BMP. This is the only format ...

VMWare Workstation – Unable to open kernel device “.\Global\vmx86” : The system cannot find the file specified

Thursday, September 10th, 2015

I recently upgraded my VMWare Workstation from Version 10 to 12. The software is running on Windows 10/64.I never had any issues with VMWare Workstation 10 on Windows 7, 8 and 8.1. But after the upgrade, almost after every restart I saw the following error message when I tried to ...

Speaking at SNoUG

Friday, September 4th, 2015

After 2013 & 2014, I again have the honor to speak at SNouG ( Swiss Notes User Group ) in Zurich on 28-Oct-2015My session is titled "Honey, I shrunk the data!". This session has been held a couple of times before at various user groups, but it seems that there ...

MWLUG2015 – Session Slides And Sample Application

Sunday, August 23rd, 2015

MWLUG 2015 in Atlanta was a blast. Thanks to all, who have organized the event. Also a big thank you to all, who attended my session.Here is the presentation and the sample database & XML dataDOWNLOAD 

More Magic For TeamCity Build Automation

Wednesday, August 12th, 2015

I recently added a great plugin to my TeamCity configuration that makes the deployment of new releases simple. The plugin adds some new deployers to the TeamCity server.I am using the FTP Deployer.The deploy-64 build step opens a connection to my FTP server and uploads files that have been built.In ...

Building a commandline interface with boost::program_options

Sunday, July 26th, 2015

My ONTF project "DomBackUp" can be configured and run via the command-line without having the configuration database installed on the Domino server. DomBackUp is a fork of nKBackup by Tom Lyne et al. I found the command-line interface code a bit hard to maintain when it comes to enhancements. So I was ...

Building ONTF DomBackUp with TeamCity

Sunday, July 26th, 2015

Building binaries for multiple platforms from source is time consuming. For my ONTF project "DomBackUp" I have to build binaries for AIX (not sure, if I can support AIX in future builds ) , LINUX and Windows, both on 32Bit and 64Bit.Aside from Atlassian JIRA and STASH, a couple of ...

[CMake] How to turn off incremental linking

Friday, July 17th, 2015

I recently had to build a static library using CMake. In the current CMake version, apparently something has changed in the linker settings.The build always ended with an error: LINK : fatal error LNK1123: failure during conversion to COFF: file invalid or corrupt [D:\0.GIT\libarchive-3.1.2\vc10.32\CMakeFiles\CMakeTmp\cmTC_bbd0c.vcxproj] Looking at the linker settings, I found that CMake ...

Code Quest

Thursday, July 16th, 2015

A couple of days ago, I had to investigate on an issue in a rather old template. The template had been delivered to a customer ages ago. After downloading the template from the repository ( no, not from a GIT or SVN repository ) and after Domino Designer had opened ...

TeamCity Start/Stop Script for Linux

Thursday, June 11th, 2015

I am using Teamcity on Ubuntu 14.04. Here is a simple script to start / stop TeamCity server.#!/bin/sh # /etc/init.d/teamcity - startup script for teamcity export TEAMCITY_DATA_PATH="/home/teamcity/.BuildServer" export TEAMCITY_SERVER_OPTS=-Djava.awt.headless=true # Configure TeamCity for use on a headless OS. case $1 in ...

install git on SLES 11 SP 3

Saturday, June 6th, 2015

sudo zypper addrepo http://download.opensuse.org/repositories/devel:/tools:/scm/SLE_11_SP3/devel:tools:scm.repo sudo zypper addrepo http://download.opensuse.org/repositories/devel:/languages:/perl/SLE_11_SP3/devel:languages:perl.reposudo zypper install git-core

Execute A Program From A C / C++ Program

Friday, May 22nd, 2015

To start an external program from a C / C++ program, I used the following code. GetStartupInfo( &start_info ); // You must fill in this structure ret = CreateProcess( NULL,  // specify the executable program (LPSTR)buffer,   // the command line arguments NULL, NULL, FALSE, NORMAL_PRIORITY_CLASS | CREATE_NO_WINDOW, NULL, NULL, &start_info, &process_info);// Successfully created the process.  Wait for it to finish. WaitForSingleObject( process_info.hProcess, ...

Slides And Sample Application from My Presentation ( ENGAGE & ICS.UG)

Friday, April 3rd, 2015

 The presentation and sample can be downloaded here

A smallish problem installing JVMPatch_SR16FP3_W64_901.3_Server

Tuesday, March 24th, 2015

I recently ran into an issue, where my Java SQL and LDAP connectors stopped working after applying FP3 to Domino 9.0.1 / 64Bit.Thanks to the help of the community, I was pointed to an already existing fix for this issue. IBM had released an JVM patch . I downloaded the ...

A quick tipp for using the ONTF Dependency Documenter

Thursday, February 12th, 2015

A quick tipp for using the ONTF Dependency Documenter from Andrew Magerman. If you have a lot of libraries in your database, the resulting image might be too large to fit into the page and the result seems to be truncated.I have talked too Andrew already, and it seems that there ...

Serious issue when signing a database in the background on the server

Saturday, January 31st, 2015

While working with the cAPI, I ran into a nasty problem with signing design elemnts in an application on the server with a different ID than the server ID. This seems only to be a problem with XPages related design elements. When you try to open an XPage from that database in ...