Archive for the ‘Articles’ Category

Extreme slow RDP performance on Windows 2012 R2 server running on VMware ESXi

Friday, September 8th, 2017

I am running a  Windows 2012 R2 servers on a VMware ESXi environment ( 6.5.0 Update 1 (Build 5969303 ) . I experience an extreme poor performance on the Windows 2012R2 server when connection with any RDP-client ( Windows and Mac )The hardware shouldn’t be an issue.the server does not ...

SSH2_MSG_UNIMPLEMENTED packet error with PuTTY and RHEL 7.2

Friday, September 1st, 2017

I recently updated one of my RHEL 7.2 servers with yum update -y. After a reboot, I tried to connect to the machine using PuTTY client, but the connection faild with the following error:To solve the issue, open the configuration for the connection and navigate to SSH -> Kex. In ...

IBM Verse on Premises 1.0.2 available an Passport Advantage

Wednesday, August 30th, 2017

IBM Verse on Premises 1.0.2 is available an Passport Advantage. PartNo. CNL9UMLWhats new: https://www.ibm.com/support/knowledgecenter/SS4RQV_1.0.2/whats_new/wn_102.html

[FREE] – midpoints Let’s Encrypt 4 Domino (LE4D)

Wednesday, August 23rd, 2017

To enable HTTPS on your website, you need to get a certificate from a Certificate Authority. These certificates can be rather expensive, especially if you have several domains or domains that use subject alternate names (SAN).Let's Encrypt is a CA that offers certificates for FREE. The only limit is that ...

What is the SIZE of a Docker container?

Monday, August 21st, 2017

I recently was  asked, if it is possible to tell the size of a container and, speaking of disk-space, what are the costs when running multiple instances of a container.Let’s take the IBM Domino server from my previous post as an example.You can get the SIZE of a container with ...

Domino on Docker

Sunday, August 20th, 2017

IBM recently announced Docker support for Domino. It is supposed to come with FP10 at the end of this year.Domino IMHO is not a microservic, but Domino on Docker has other advantages.Think about a support person maintaining a product. All he needs to investigate a customer's issue is the data ...

[Docker CLI] – Delete Containers

Wednesday, May 31st, 2017

If you want to delete ALL containers , running or exited, you can do this with a single command. docker stop $(docker ps -a -q)docker rm $(docker ps -a -q) If you only want to delete containers that have 'exited', then use: docker ps -a | grep Exited | cut -d ' ' ...

IBM Spectrum Conductor for Containers

Tuesday, May 30th, 2017

IBM® Spectrum Conductor for Containers is a server platform for developing and managing on-premises, containerized applications. It is an integrated environment for managing containers that includes the container orchestrator Kubernetes, a private image repository, a management console, and monitoring frameworks.For my upcoming AdminCamp 2017 session later this year, I wanted ...

Notes FP8 (IF1) might stop your custom sidebar plugins from working

Thursday, May 11th, 2017

We got a call from one of our customers reporting a defect in our midpoints doc.Store sidebar plugin. It worked in Notes 9.0.1FP7 but stopped working after the upgrade to FP8.I was able to reproduce in our development environment. In the error log, we saw the following error message at lotus.domino.local.Session.FindOrCreate(Unknown ...

Install Docker On RHEL 7 in 3 Easy Steps

Friday, March 31st, 2017

You are just 3 steps away from running docker containers on a RHEL7.curl -sSL https://get.docker.com/ | sh systemctl enable docker systemctl start dockerNow you can test your installation runningdocker run hello-worldThat's it. 

C / c++ for Notes & Domino Developers

Tuesday, March 28th, 2017

C/ C++ for Notes & Domino Developers von Ulrich Krause

Fun with IBM Traveler and Java

Sunday, February 5th, 2017

Today I stumbled upon a very strange behaviour of some Java code, and I do not have any clue about the why.I am parsing the response (text) file from the "tell traveler show user" command. The response file is written to the system temp directory and contains all information that you ...

Verse on premises – first impression

Saturday, December 31st, 2016

IBM promised to deliver Verse On Premises ( VoP ) on 30-DEC-2016. And they did.I tried to download it; all I got was24 hours later, the download worked.The "installation" is a mixture of click and install and copy files from here to there. I expected something like IBM Notes Traveler ...

IBM Notes and Domino V9.0.1 extends support and enhances its collaboration toolset with social capabilities from IBM Connections V5.5

Tuesday, September 13th, 2016

read this for detailled information

Domino JNA vs. IBM Domino Java API

Sunday, September 11th, 2016

Today, I finally found the time to take a closer look into the Domino JNA project. The project has been created by Karsten Lehmann, mindoo.The goal of the project is to provide low level API methods that can be used in Java to speed-up the retrival of data; especially, if ...

ONTF DomBackup 1.0.0.5 released

Friday, April 29th, 2016

I have uploaded a new version of ONTF DomBackup. Version 1.0.0.5 contains updated binaries for Windows 32/64 Bit.It adresses an issue that leads to data losses when compressing files larger 2GB. The issue is described here. The issue is Windows related only!The fixed version uses 7Zip as an external compression ...

DAOS – Find a note for a missing NLO file

Tuesday, March 8th, 2016

Today, I saw the following message on my Domino console[0E88:005A-0FF4] 08.03.2016 17:19:01   The database d:\Domino\data\mail\ukrause.nsf was unable to open or read the file d:\DAOS\0002\97FC43BEED143800A6608E557BE888498DB9BC5100015B7C.nlo: File truncated - file may have been damagedIf you see such a message in your production environment, you should immediately find outwhat causes the damage? which ...

Windows Fixpack Update Idiocy

Sunday, February 28th, 2016

Today I decided to install some recommended and optional fixes on my "productive" Windows 2008 R2 /64 Server.In general, this has been a straight-forward task in the past. Select all fixes and click Install. Grab a new cup of coffee, restart the machine after upgrade and carry on with daily ...

[Vaadin] – Create a simple twin column modal multi-select dialog

Saturday, January 30th, 2016

Vaadin is an open source Web application framework for rich Internet applications. In contrast to JavaScript libraries and browser-plugin based solutions, it features a server-side architecture, which means that the majority of the logic runs on the servers. Ajax technology is used at the browser-side to ensure a rich and ...

Latest Windows 10 update completely wrecked my dev environment

Tuesday, January 5th, 2016

I am doing dev with Visual Studio and other tools and programs on a Windows 10 VM. Today, I decided to check for updates and install them, because I had not done any update for the past 2 month.In general, these updates do not d any harm to the installed ...